OBDTUNER V2

Prépas moteur et autres modifications

Modérateurs: Stew, blacksrookie, Puff92

OBDTUNER V2

Messagepar SV13 » Dim Avr 28, 2013 6:33 pm

Bonjour à tous,

J'ai a peu près bouclé mon montage de compresseur M62 sur mon VX.
En cours de chantier, j'ai changé mon option initiale qui était de poster mon ECU chez Courtenay, et j'ai fait modifier l'ECU pour pouvoir utiliser OBDtuner.
Comme je n'ai aucune expérience de mise au point moteur, mais que j'aime bien bricoler, j'ai trouvé ça intéressant.
Jusqu'à présent, ça c'est parfaitement bien passé, et le forum a été une mine d'or, et aussi VX220.uk.org our leur rendre justice.
Je n'ai pas posté avant car je n'avais rien de nouveau à ajouter.

La seule information nouvelle par rapport à ce qui a déjà été fait serait peut être que j'ai monté sur le compresseur le capteur TMap sensor 3.0 Bar (Bosch 0 281 002 437), qui mesure pression et température dans l'admission.
L'info de température est utilisée pour corriger la richesse.
Pour info, un résumé de ce que j'ai fait sur la voiture:
- TMap sensor 3.0 Bar (Bosch 0 281 002 437)
- EGR supprimée
- Lambda 2 supprimée
- Recirculation vapeurs essence supprimée
- Filtre à air Honda S2000
- Eaton compressor M62 avec poulie 3,1" (79mm)
- Papillon LSJ 68mm
- Dual pass avec échangeur sous radiateur d'origine
- 4 injecteurs de Speedster Turbo.
- Rupteur à 6400
- Thermostat 82°
- Déclenchement ventilateur à 92°

Pour l'instant, la voiture démarre parfaitement, le ralenti à froid et à chaud est nickel, et c'est un avion de chasse. Quel pied!!! :devil2:
J'ai fait une première acquisition de données qui a très légèrement fait évoluer la cartographie de base que m'avait été fournie.
Pour être franc, la voiture tournait déjà très bien avec la première cartographie.
Et je n'ai pas encore ajusté la courbe d'avance à l'allumage.

Donc voici ma première question:
pourquoi ma courbe de couple a t'elle cette tête là?
J'ai fait deux runs, qui se superposent bien, un où je suis allé au rupteur à 6400, et l'autre ou j'ai levé le pied avant.
Je me fiche un peu des valeurs maxi qui ne sont qu'indicatives avec ce type de mesures, mais j'avais en tête des courbes nettement plus progressives que ça et je ne m'explique pas cette variation en plein milieu de la plage de régime.
Est ce que cela vient de la mise en action du compresseur?
En bref, est ce que c'est normal, ou y a t'il un problème quelque part (courroie qui ripe...).:voyons:
Image

merci de vos avis.
Stéphane
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Re: OBDTUNER V2

Messagepar Balky » Dim Avr 28, 2013 6:55 pm

Avec quoi tu fais tes mesures?
Ce n'est pas une courbe de compresseur ça..

SV13 a écrit:L'info de température est utilisée pour corriger la richesse.


Non, elle est utilisée pour corriger l'avance.
Balky
 
Messages: 667
Inscription: Sam Avr 28, 2007 8:38 pm
Localisation: 16

Messagepar Grillon » Dim Avr 28, 2013 6:55 pm

En effet, ça n'a pas l'air très progressif. Est-ce que ça se ressent à la conduite?

Sinon, est-ce que tu as un moyen de vérifier que le lambda et l'avance sont progressifs?
Photos ISM
Nom d'utilisateur = myspeedster
Mot de passe = ism
Avatar de l’utilisateur
Grillon
 
Messages: 3494
Inscription: Ven Mar 14, 2008 7:26 pm
Localisation: + Verneuil-sur-Seine (78)

Re: OBDTUNER V2

Messagepar Grillon » Dim Avr 28, 2013 6:56 pm

Balky a écrit:
SV13 a écrit:L'info de température est utilisée pour corriger la richesse.


Non, elle est utilisée pour corriger l'avance.

Ah je me disais aussi que je ne voyais pas le rapport :D
Photos ISM
Nom d'utilisateur = myspeedster
Mot de passe = ism
Avatar de l’utilisateur
Grillon
 
Messages: 3494
Inscription: Ven Mar 14, 2008 7:26 pm
Localisation: + Verneuil-sur-Seine (78)

Messagepar SV13 » Dim Avr 28, 2013 7:44 pm

Merci de vos réponses.
Je viens de vérifier, dans OBDtuner, la prise d'info de température d'admission (après le compresseur) sert à corriger l'AFR.
Il y a une table qui s'appelle : "Open loop target AFR correction for inlet air temperature".
A confirmer, mais d'après ce que vois dans la doc, les tables d'avance dépendent du régime et de la charge, mais pas de la température.

La courbe couple puissance est obtenue comme dans powerdyn, le logiciel relève l'évolution du régime moteur en fonction du temps, et en déduit une courbe de couple sur la base de données propres au véhicule et à la météo, puis une courbe de puissance, sur la base P=Cw. Au final, c'est plutôt l'évolution des courbes obtenues en fonction des modifs sur la voiture, qui est intéressante, plutôt que les valeurs obtenues.
Ca fait un banc à pas cher.
Sinon, d'après le graphe, j'aurai 327CV à l'arbre moteur.... ::::

A la réflexion, la chaussée était bien mouillée aujourd'hui, c'est peut être un décrochage des roues arrière, mais je ne l'ai pas senti. Je referai un essai par temps sec.
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar Balky » Dim Avr 28, 2013 7:57 pm

SV13 a écrit:Merci de vos réponses.
Je viens de vérifier, dans OBDtuner, la prise d'info de température d'admission (après le compresseur) sert à corriger l'AFR.
Il y a une table qui s'appelle : "Open loop target AFR correction for inlet air temperature".
A confirmer, mais d'après ce que vois dans la doc, les tables d'avance dépendent du régime et de la charge, mais pas de la température.


Tu ne confonds pas avec la sonde de température d'air en amont papillon?
Balky
 
Messages: 667
Inscription: Sam Avr 28, 2007 8:38 pm
Localisation: 16

Messagepar SV13 » Dim Avr 28, 2013 8:04 pm

Non, elle n'existe plus.
C'est la particularité de ce montage avec un capteur pression+temp localisée sur le collecteur, après le compresseur.
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar Balky » Dim Avr 28, 2013 8:42 pm

Normalement les 2 sont utilisées.
Bref, je ne comprends pas ce montage..
Balky
 
Messages: 667
Inscription: Sam Avr 28, 2007 8:38 pm
Localisation: 16

Messagepar Grillon » Dim Avr 28, 2013 8:55 pm

SV13 a écrit:Je viens de vérifier, dans OBDtuner, la prise d'info de température d'admission (après le compresseur) sert à corriger l'AFR.
Il y a une table qui s'appelle : "Open loop target AFR correction for inlet air temperature".

Ah je pense comprendre : la T° d'air sortie compresseur doit servir à estimer le remplissage en air du moteur (ou le débit), et donc la quantité de carburant à injecteur pour obtenir une richesse donnée. Donc d'une certain manière (question de vocabulaire) à ajuster la richesse.
Ca n'empêche pas qu'elle puisse également servir à ajuster l'avance pour du préventif cliquetis.

Et effectivement je ne vois pas l'intérêt d'une sonde en amont papillon s'il y en a une en aval compresseur, puisqu'en gros c'est au même endroit non?

Sinon je n'avais pas compris que la mesure de couple/puissance était faite en dynamique, ça explique sans doute en grande partie le manque de précision et l'aspect chahuté de la courbe. Peut-être peux-tu essayer en partant de différents régimes?
Photos ISM
Nom d'utilisateur = myspeedster
Mot de passe = ism
Avatar de l’utilisateur
Grillon
 
Messages: 3494
Inscription: Ven Mar 14, 2008 7:26 pm
Localisation: + Verneuil-sur-Seine (78)

Messagepar SV13 » Dim Avr 28, 2013 11:55 pm

Pour ce que j'en comprends, la prise de température après la compression permet justement de prendre en compte l'élévation de la température liée à la compression.
J'insiste, mais c'est un seul et même capteur qui mesure pression et température en aval du compresseur, et le logiciel est à paramétrer comme ça. Ce capteur TMAP a la même tête que le capteur de pression d'origine. Je peux mettre de la doc la dessus, mais je ne sais pas insérer des pdf.
(Mais avec ODBtuner, on peut aussi garder la température amont, et la prise de pression aval, comme dans tous les montages que j'ai pu voir sur le net).

L'estimation du débit volumique de l'air comprimé doit être plus précise en connaissant la température après le compresseur.
Et l'intérêt de la chose, c'est justement que le logiciel prend en compte la diminution de la masse d'air admise quand la température de l'air augmente. C'est pas mal foutu.

Pour ma part, même avec un échangeur et le dual pass, à l'arrêt, en statique, quand la température d'eau de refroidissement est à 95°, la température de l'air comprimé est à 65° stabilisé.
En roulant, la température de l'air est environ à 55°.

Pour ce qui est de la courbe obtenue, j'ai peut être posté un peu vite, je referai ça par temps sec. C'est sûr que si une roue patine, ça correspond plus à rien, et c'est ce qui a du se passer.
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar Balky » Lun Avr 29, 2013 8:17 am

Pas de soucis avec ce capteur Tmap, j'utilise le même, c'est le montage LSJ.

Ce que je ne comprends pas, c'est que ce capteur (double) doit également permettre une correction de la map avance en fonction de l'élévation de la tempé d'admission justement.
Balky
 
Messages: 667
Inscription: Sam Avr 28, 2007 8:38 pm
Localisation: 16

Messagepar SV13 » Mer Mai 15, 2013 5:46 pm

Mon VX a fait sa première sortie sur circuit, et je dois bien avouer qu'il y a des points que j'ai un peu négligé et qu'il va falloir que j'améliore.
J'ai des petits soucis, et je pense que tout est un peu lié à des pb de températures d'admission excessives.

Pour commencer, j'ai refait un run dans de meilleures conditions pour ressortir une courbe moyenne de couple et de puissance qui a une bien meilleure tête que celle que j'ai mis en début de post.
Il faut donc que le tronçon de route utilisé soit très plat, et sec, sinon ça donne des courbes très polluées.
La valeur de puissance que j'obtiens est de 227CV, mais à 6200trs seulement (et pour l’instant avec une cartographie d'allumage très safe).

Mes soucis:
J'ai beau avoir mis des injecteurs de Speedster Turbo, ils saturent quand même vers 5400trs (on peut le voir sur les log avec OBDTUNER)
Mon installation Chargecoller à pas cher brille d'une inefficacité redoutable, surtout dans la file d'attente avant de rentrer en piste.
Le moteur en lui même chauffe un poil plus qu'avant, mais la température admission atteint des sommets inavouables.

Donc la voiture est parfaitement utilisable au quotidien, mais sur circuit, mon montage trouve rapidement ses limites.

Donc je vais revoir ma copie:
- changement pompe à essence et peut être un réservoir tampon. J'ai eu quelques coupures d'alim assez franches et avant le rupteur, ce qui n'arrivait pas avant le passage au compresseur, et je ne sais pas vraiment d'où ça vient. Je n'avais jamais déjaugé avant, et je me demande pourquoi ça le ferait maintenant. Peut être que c'est la pompe qui est en train de lâcher.
- Injecteurs plus gros (40lbs)
- et surtout montage du charge cooler de Proalloy avec 2 ventilateurs,au lieu d'un seul actuellement. Ca devrait améliorer les choses à tout point de vue.

Est ce que certains ici ont monté ce chargecooler, et ont relevé les températures admission dans différentes configurations?
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar Balky » Mer Mai 15, 2013 6:47 pm

Ils sont a quel pourcentage d'ouverture (duty cycle) tes injecteurs?
Tu es comment en AFR?
Balky
 
Messages: 667
Inscription: Sam Avr 28, 2007 8:38 pm
Localisation: 16

Messagepar Happy Speedy » Mer Mai 15, 2013 6:53 pm

Alors moi j'ai monté le CC proalloy sur mon turbo et j'avoue en être pleinement satisfait même si je n'ai pas encore extrait de log sur piste.
Dans tous les cas, la différence est flagrante :jap:

De mon côté, j'ai également monté un seul ventilo au lieu des 2, espacé le plus possible les 2 radias et canalisé le flux entre les deux en obstruant les espaces avec de la mousse double face :jap:

Aucune chauffe excessive de l'eau même sur piste et un seul ventilo suffit à faire le boulo pour abaisser la température :jap: Je suis même convaincu que le refroidissement ne peut être que meilleur car cela augmente considérablement les pertes de charges de mettre les 2 ventilos :jap:
Avatar de l’utilisateur
Happy Speedy
 
Messages: 17146
Inscription: Dim Nov 11, 2007 7:37 pm
Localisation: +IDF 95

Messagepar Polo77 » Mer Mai 15, 2013 7:08 pm

:-><:

intéressant ce sujet,

c'est cool de partager ton retour d'expérience ici :jap:
Avatar de l’utilisateur
Polo77
 
Messages: 1305
Inscription: Lun Juil 02, 2012 9:33 pm
Localisation: + seine et marne

Messagepar WqTcHq-St » Mer Mai 15, 2013 7:57 pm

J'ai le proalloy sur mon sc, les températures ne dépassent jamais 30° sur route et 40° sur circuit. J'ai déjà vu un 50° à Ledenon par forte température vers le début du montage mais j'avais encore de l'air dans le circuit... Encore ce wk j'étais à 40° sur le circuit d'issoire :jap:
Je pense que c'est le montage le plus efficace
Par contre, Le rendement des ventilos spal sur le proalloy n'est pas meilleur donc vu la différence de taille des ventilos (1/3 de la surface) tu auras plus de mal à faire baisser la température avec un ventilo (pas gênant si tu ne fais pas de bouchons... et si tu as un radiateur alu).
Maintenant, au niveau refroidissement moteur les 2 ventilos n'obstrues pas (en tout cas de façon significative le refroidissement). Je pense que ce qu'il y a à gagner est léger (m'enfin le concept d'allègement est la :II: ).
Sinon moi mon moteur ne chauffe pas plus à cause du compresseur, sur route je suis entre 85 et 87° selon températures sur route et 90/92° sur circuit sans thermostat 82°... donc c'est peut être du à tes réglages de carto.

Pour les coupures, c'est normal que tu déjauges, tu as beaucoup + de puissance et les G/transfert de masses... sont plus important ce qui crée ces coupures, comme sur le turbo. Soit tu montes un réservoir soit tu roule avec la moitié du plein tout le temps sur piste.
Avatar de l’utilisateur
WqTcHq-St
 
Messages: 4217
Inscription: Dim Jan 10, 2010 5:53 pm
Localisation: Montpellier+

Messagepar Brett » Mer Mai 15, 2013 8:32 pm

WqTcHq-St tu parles de température d'admission ou temperature du liquide de refroidissement?

Sur le banc avec les injecteurs z20let saturaient autour de 250cv brut à 7000tpm en gardant une température d'échappement correcte. Je suis passé à des 470cc maintenant plus de pb.
Avec 227cv faire saturer les injecteurs à 5400tpm, il y a un truc.
Il n'y a pas de fumée sans pneu!
Avatar de l’utilisateur
Brett
 
Messages: 776
Inscription: Dim Oct 29, 2006 5:39 pm
Localisation: Barr

Messagepar WqTcHq-St » Mer Mai 15, 2013 8:40 pm

Brett a écrit:WqTcHq-St tu parles de température d'admission ou temperature du liquide de refroidissement?

Sur le banc avec les injecteurs z20let saturaient autour de 250cv brut à 7000tpm en gardant une température d'échappement correcte. Je suis passé à des 470cc maintenant plus de pb.
Avec 227cv faire saturer les injecteurs à 5400tpm, il y a un truc.


A oui des températures d'eau du circuit du compresseur :II:
Avatar de l’utilisateur
WqTcHq-St
 
Messages: 4217
Inscription: Dim Jan 10, 2010 5:53 pm
Localisation: Montpellier+

Messagepar Brett » Mer Mai 15, 2013 8:53 pm

Ce qui est vraiment important c'est la température d'admission. Il n'existe pas vraiment de relation entre la temp. d'admission et la température du liquide. Du coup pour comparer avec SV13 c'est compliqué.
Il n'y a pas de fumée sans pneu!
Avatar de l’utilisateur
Brett
 
Messages: 776
Inscription: Dim Oct 29, 2006 5:39 pm
Localisation: Barr

Messagepar WqTcHq-St » Mer Mai 15, 2013 8:55 pm

Brett a écrit:Ce qui est vraiment important c'est la température d'admission. Il n'existe pas vraiment de relation entre la temp. d'admission et la température du liquide. Du coup pour comparer avec SV13 c'est compliqué.


Oui j'avais mal lu ::::
Avatar de l’utilisateur
WqTcHq-St
 
Messages: 4217
Inscription: Dim Jan 10, 2010 5:53 pm
Localisation: Montpellier+

Messagepar SV13 » Jeu Mai 16, 2013 12:15 am

Merci de votre intérêt pour mon bricolage.
Pour répondre en vrac, les températures d'admission avec le pro alloy me laissent rêveur. J'aurais du y venir tout de suite car je vais devoir me retaper un démontage de masque avant pour en monter un.
En l'état, mes temp sont plutôt sur une base de 65°, voir 70° en situation bouchon (ce sont les temp de l'air aval compresseur), c'est clair que cela se stabilise trop haut. 40° serait formidable, mais j'en suis loin.
Avec une poulie de 3,1", j'ai un boost qui frise les 200kPa, ça doit activement participer à l'augmentation de température.
Le moteur en lui même (eau refroidissement) ne chauffe pas beaucoup plus qu'avant.

J'ai ressorti un log, sur lequel le duty cycle des injecteurs est à 91.1% pour 4900trs, et une pression de 190kPa.
Un autre où ils sont à 82% à 4838trs, et une pression de 188kPa.
J'ai malheureusement pas enregistré celui où j'ai vu les injecteurs à 100%.
Je ne comprends pas non plus pourquoi ils sont au taquet, alors que les spécialistes du sujet s'accordent à dire que ça peut aller jusqu'à 250CV. D'autant que mon air aussi chaud, donc moins d'O2, devrait aller dans le bon sens pour les injecteurs (moins d’essence)

Mon afr cible dans cette zone là de rpm est de 11.7.
D'ailleurs, la table de "target afr" est très rapidement de 11.7 ou 11.8 dès qu'on dépasse les 1 bars quels que soient les rpm. J'ai l'impression que c'est bien riche tout de suite.
Il faut dire que la cartographie fine de l'injection, avec ODBtuner, se fait en basculant l'ECU en boucle ouverte et en mode auto-apprentissage. L'ECU adapte donc la table de base, pour coller au mieux aux valeurs d'afr de la table cible.
Est ce que qqun sait comment faire pour vérifier et valider les tensions délivrées par la sonde lambda (qui doit avoir l'âge de la voiture)?Peut être que je suis beaucoup trop riche et que les injecteurs saturent trop tôt.

Pour les coupures d'alim, est ce que c'est un phénomène connu sur le Speedster? Et qu'est ce qu'il faut faire pour combattre ça. C'est pas rassurant de se dire que le mélange peut devenir très pauvre brutalement.
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar bad boy » Jeu Mai 16, 2013 7:59 am

je vais certainement faire un montage comme le tien , donc ça m'intéresse fichtrement ton installation :II:
pour ton problème le capteur de cliquetis ne fait il pas des siennes ?
2.2 gris banalisé n°1791
il n'en existe que 3 dans le monde , Chuck Norris a la quatrième
Avatar de l’utilisateur
bad boy
 
Messages: 14234
Inscription: Ven Oct 19, 2007 6:43 pm
Localisation: + mareuil sur lay

Messagepar Brett » Jeu Mai 16, 2013 8:30 am

SV13 a écrit: j'ai un boost qui frise les 200kPa, ça doit activement participer à l'augmentation de température.


Si tu as réellement 200kPa tu vas avoir d'autres problèmes...
Juste pour info 200kPa = 2 bar c'est juste impossible avec le M62. Ton capteur déconne ou est mal calibré c'est peut-être pourquoi tes injecteurs sont au max.
Avec une poulie de 3" j'ai environ 0,75bar.

SV13 a écrit: Mon afr cible dans cette zone là de rpm est de 11.7.
D'ailleurs, la table de "target afr" est très rapidement de 11.7 ou 11.8 dès qu'on dépasse les 1 bars quels que soient les rpm. J'ai l'impression que c'est bien riche tout de suite.
Il faut dire que la cartographie fine de l'injection, avec ODBtuner, se fait en basculant l'ECU en boucle ouverte et en mode auto-apprentissage. L'ECU adapte donc la table de base, pour coller au mieux aux valeurs d'afr de la table cible.
Est ce que qqun sait comment faire pour vérifier et valider les tensions délivrées par la sonde lambda (qui doit avoir l'âge de la voiture)?Peut être que je suis beaucoup trop riche et que les injecteurs saturent trop tôt.


Tu as une sonde large bande? Je crois comprendre que non alors tes target cela ne sert à rien...
Il n'y a pas de fumée sans pneu!
Avatar de l’utilisateur
Brett
 
Messages: 776
Inscription: Dim Oct 29, 2006 5:39 pm
Localisation: Barr

Messagepar Balky » Jeu Mai 16, 2013 8:35 am

Ne t'emmerde pas avec une lambda d'occase, colles-en une neuve.
Il faudrait que tu rajoutes une large bande, au moins pour avoir une lecture précise de l'AFR, ce qui est impossible avec une narrow band, parce que la, tu est
un peu dans le brouillard..

La narrow band est suffisante pour faire fonctionner ton ECU, mais pour "concevoir" une carto propre, la large bande est indispensable.

Sur mon speedy, j'ai gardée l'affichage de la large bande au tableau, et l'ECU fonctionne avec la narrow.

11.7 au taquet, ça peut aller, c'est un poil riche mais sécurisant.. Par contre, sur les intermédiaires, ça pourrait être plus pauvre, ça doit pisser l'essence, la!

Oui, 2 bars avec une 3,1", même en pression absolue, ce n'est pas possible.
Balky
 
Messages: 667
Inscription: Sam Avr 28, 2007 8:38 pm
Localisation: 16

Messagepar SV13 » Jeu Mai 16, 2013 9:26 am

Je vous joins un extrait de log.
Image
Le graphe du haut: Temp eau moteur, Temp air admission, et duty injecteur
Le graphe du bas : pression admission.
Les deux pics correspondent à une pointe à 170environ, injecteurs à 82%, et 188kPa.

Est ce que les kPa relevés par le capteur ne sont pas à lire en relatif en soustrayant la pression atmosphérique.
Ce qui ferait arriver en toute logique à 0.82bars de compression effective par rapport à l'ambiant.
C'est un peu la boite noire, je n'ai pas les moyens d'étalonner ce capteur Tmap, et il est neuf.
Je vais poser la question à Peter, car c'est effectivement intriguant. Il a peut être truandé les échelles de lectures pour faire marcher les capteurs, parce que, tout de même, le moteur marche bien, est souple, il ne ratatouille pas. Il doit y avoir une explication.

Non, je n'ai pas (encore) de lambda large bande, mais je vais devoir y venir si je continue à faire mumuse avec ces mises au point.
Et je vais peut être remplacer ma sonde lambda de façon préventive.

La table target AFR ne sert qu'une fois dans ODBTUNER, quand le soft fait son auto apprentissage et il le fait sur la base de la sonde lambda d'origine.
Il faut aller rouler pendant un long moment en essayant de remplir toutes les cases (rpm et pression). Chaque cellule est validée à partir du moment où au moins 200 mesures ont été effectuées pour la cellule concernée. Ensuite le soft fait évoluer, ou pas, les valeurs de la table fuel initiale.

En tout cas, merci de vos retours, ça me fait des pistes à explorer, qui pourraient expliquer pourquoi les injecteurs saturent.
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar VX'er » Jeu Mai 16, 2013 11:15 am

Brett a écrit:
SV13 a écrit: j'ai un boost qui frise les 200kPa, ça doit activement participer à l'augmentation de température.


Si tu as réellement 200kPa tu vas avoir d'autres problèmes...
Juste pour info 200kPa = 2 bar c'est juste impossible avec le M62. Ton capteur déconne ou est mal calibré c'est peut-être pourquoi tes injecteurs sont au max.
Avec une poulie de 3" j'ai environ 0,75bar.

SV13 a écrit: Mon afr cible dans cette zone là de rpm est de 11.7.
D'ailleurs, la table de "target afr" est très rapidement de 11.7 ou 11.8 dès qu'on dépasse les 1 bars quels que soient les rpm. J'ai l'impression que c'est bien riche tout de suite.
Il faut dire que la cartographie fine de l'injection, avec ODBtuner, se fait en basculant l'ECU en boucle ouverte et en mode auto-apprentissage. L'ECU adapte donc la table de base, pour coller au mieux aux valeurs d'afr de la table cible.
Est ce que qqun sait comment faire pour vérifier et valider les tensions délivrées par la sonde lambda (qui doit avoir l'âge de la voiture)?Peut être que je suis beaucoup trop riche et que les injecteurs saturent trop tôt.


Tu as une sonde large bande? Je crois comprendre que non alors tes target cela ne sert à rien...


Si justement, le target AFR existe parce qu'il a une narrow band.
Le principe du target AFR c'est de déterminer par la Lambda narrow band lla quantité d'essence qui donne du stochio (14.7). Ensuite le target AFR effectue un calcul et permet d'ajouter une quantité d'essence en fonction de la target AFR désirée et des paramètres moteurs.
C'est pour ça qu'on dit target AFR(la cible) atteinte par calcul et non mesurée directement par la sonde lambda.
Avatar de l’utilisateur
VX'er
 
Messages: 2228
Inscription: Lun Avr 24, 2006 9:28 pm
Localisation: 31

Messagepar Brett » Jeu Mai 16, 2013 12:39 pm

VX'er a écrit:
Brett a écrit:
SV13 a écrit: j'ai un boost qui frise les 200kPa, ça doit activement participer à l'augmentation de température.


Si tu as réellement 200kPa tu vas avoir d'autres problèmes...
Juste pour info 200kPa = 2 bar c'est juste impossible avec le M62. Ton capteur déconne ou est mal calibré c'est peut-être pourquoi tes injecteurs sont au max.
Avec une poulie de 3" j'ai environ 0,75bar.

SV13 a écrit: Mon afr cible dans cette zone là de rpm est de 11.7.
D'ailleurs, la table de "target afr" est très rapidement de 11.7 ou 11.8 dès qu'on dépasse les 1 bars quels que soient les rpm. J'ai l'impression que c'est bien riche tout de suite.
Il faut dire que la cartographie fine de l'injection, avec ODBtuner, se fait en basculant l'ECU en boucle ouverte et en mode auto-apprentissage. L'ECU adapte donc la table de base, pour coller au mieux aux valeurs d'afr de la table cible.
Est ce que qqun sait comment faire pour vérifier et valider les tensions délivrées par la sonde lambda (qui doit avoir l'âge de la voiture)?Peut être que je suis beaucoup trop riche et que les injecteurs saturent trop tôt.


Tu as une sonde large bande? Je crois comprendre que non alors tes target cela ne sert à rien...


Si justement, le target AFR existe parce qu'il a une narrow band.
Le principe du target AFR c'est de déterminer par la Lambda narrow band lla quantité d'essence qui donne du stochio (14.7). Ensuite le target AFR effectue un calcul et permet d'ajouter une quantité d'essence en fonction de la target AFR désirée et des paramètres moteurs.
C'est pour ça qu'on dit target AFR(la cible) atteinte par calcul et non mesurée directement par la sonde lambda.


Je croyais qu'il s'agissait d'une table AFR par rapport à une mesure.
Par calcul il y a tellement de paramètres à prendre en compte que je me pose la question de l'exactitude.
Il n'y a pas de fumée sans pneu!
Avatar de l’utilisateur
Brett
 
Messages: 776
Inscription: Dim Oct 29, 2006 5:39 pm
Localisation: Barr

Messagepar VX'er » Jeu Mai 16, 2013 1:59 pm

Effectivement, on peut douter de l'exactitude.

Avec OBDtuner V2 on peut maintenant brancher une wide band et verifier que l'AFR correspond à la target demandée.
Avatar de l’utilisateur
VX'er
 
Messages: 2228
Inscription: Lun Avr 24, 2006 9:28 pm
Localisation: 31

Messagepar SV13 » Jeu Mai 16, 2013 5:29 pm

Je me trompe peut être, mais pour ce que j'en ai compris:

1 - en fonctionnement normal
- au ralenti et aux moyennes charges, l'ECU est en boucle fermée et ajuste l'afr sur les infos de la sonde lambda (et d'autres paramètres temp, pression...)
- aux fortes charges et pleins régimes, l'ECU est en boucle ouverte, et va chercher les temps d'ouverture d'injecteurs dans une table préétablie (et d'autres paramètres temp, pression...). La sonde lambda ne sert plus à rien.

2 - Peter, en même temps qu'il renvoie l'ECU crakée, envoie une configuration de base qui permet déjà au moteur de fonctionner, en fonction des données de moteur et des modifs effectuées.
Pour établir la cartographie optimisée du §1 ci dessus, (et c'est peut être une spécificité d'OBDTUNER), il faut procéder à un auto apprentissage.
Ce mode bascule l'ECU en boucle ouverte, et l'ECU essaye, en partant de la carto déjà implantée, et des valeurs cibles d'afr, d'ajuster l'afr à la valeur cible souhaitée.
C'est une manip qui se fait sur la route, et il faut un moment avant d'avoir rempli un maximum de cellules du tableau.
Je pense que l'évaluation de l'afr se fait avec la sonde lambda d'origine, et le soft valide les valeurs de temps d'injection, cellule par cellule, une fois qu'il a fait au moins 200 acquisition par cellule. La sonde lambda d'origine, vu le nombre d'acquisition, doit être suffisante pour valider un temps d'ouverture d'injecteur, pour lequel l'ECU doit bien voir si on est plutôt en dessus ou en dessous de la cible. Une fois que cette acquisition est réalisée, la table fuelling est mise à jour de façon définitive.

On rebascule alors en fonctionnement normal, pour lequel les infos de sonde lambda ne sont pas exploitée à haut régime, mais uniquement la nouvelle table des temps d'injection en fonction du couple régime-pression.

Les autres tables, qui font évoluer cette carto d'injection en fonction d'autres paramètres (températures, cliquetis, action sur la pédale d'accélérateur...) ne sont pas concernées par cet auto apprentissage, et fonctionnent comme sur un ECU d'origine.

Effectivement, on peut, avec la Version 2, brancher une large bande, (sur une des bornes de la vanne EGR) et vérifier que tout cela est cohérent.
Ça permet aussi de sécuriser à haut régime la phase d'auto apprentissage, en évitant d'être trop pauvre à haut régime.
Il faudrait que je m'en fasse prêter une.
Ça me permettrait de tester ma sonde lambda pré cata, pour voir si ce n'est pas elle qui fout la merde.
Avatar de l’utilisateur
SV13
 
Messages: 220
Inscription: Mar Nov 15, 2011 3:22 am
Localisation: +Martigues

Messagepar VX'er » Jeu Mai 16, 2013 9:18 pm

Tu as raison, je doit compléter ma réponse.

C'est seulement dans la phase d'apprentissage que la sonde narrow band est utilisée en boucle fermée pour toutes les conditions de roulage.
L'apprentissage se fait en stochio
(Y'a d'ailleurs un risque associé à cette phase)

En mode normal, la target AFR est utilisé pour modifier certaines valeurs de la map (lorsqu' utilisées en boucle ouverte) . Il modifie par calcul les données apprises (stochio) ou celles de la map de base si tu n'as pas encore fait d'apprentissage.
Avatar de l’utilisateur
VX'er
 
Messages: 2228
Inscription: Lun Avr 24, 2006 9:28 pm
Localisation: 31

Suivante

Retourner vers Préparation sur le Speedster

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités